Υπολογισμός Δείκτη Μάζας Σώματος

Επισκόπηση προηγούμενης Θ.Ενότητας Επισκόπηση επόμενης Θ.Ενότητας Πήγαινε κάτω

Υπολογισμός Δείκτη Μάζας Σώματος

Δημοσίευση  Stavkor Την / Το Παρ Οκτ 08, 2010 9:55 pm

Πραγματικά δεν είναι καμιά τρομερή άσκηση,αλλά είναι ωραία για practice.
Ο ΔΜΣ υπλογίζεται ως εξής.Ο χρήστης δίνει το βάρος του σε κιλά και το ύψος του σε μέτρα.το πρόγραμμα βρίσκει τον δείκτη με τον τύπο: βάρος/(ύψος^2) και εμφανίζει τα ανάλογα μηνύματα:αν είναι μικρότερος ή ίσος του 20 τότε το άτομο είναι αδύνατο και πρέπει να πάρει κιλά,αν είναι ανάμεσα σε 20 (ή και ίσο) με 25 τότε το άτομο είναι στα κανονικά όρια,αν είναι μεγαλύτερος του 25 και μικρότερος ή ίσος του 30 τότε το άτομο είναι υπέρβαρο.Αν ο δείκτης είναι μεγαλύτερος του 30 τότε το άτομο είναι παχύσαρκο.
Σπόιλερ:

Αλγόριθμος ΔΜΣ
ΑΡΧΗ
ΕΜΦΑΝΙΣΕ 'ΔΩΣΕ ΤΟ ΒΑΡΟΣ'
ΔΙΑΒΑΣΕ Β
ΕΜΦΑΝΙΣΕ 'ΔΩΣΕ ΤΟ ΥΨΟΣ'
ΔΙΑΒΑΣΕ Υ
Δ <-- Β/(Υ^2)
ΕΜΦΑΝΙΣΕ ' Ο ΔΕΙΚΤΗΣ ΜΑΖΑΣ ΣΩΜΑΤΟΣ ΕΙΝΑΙ ', Δ
ΑΝ Δ <= 20 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΑΔΥΝΑΤΟΣ.ΠΡΕΠΕΙ ΝΑ ΤΡΩΤΕ ΠΕΡΙΣΣΟΤΕΡΟ '
ΑΛΛΙΩΣ_ΑΝ Δ > 20 ΚΑΙ Δ <= 25 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ 'ΕΙΣΤΕ ΣΤΑ ΚΑΝΟΝΙΚΑ ΟΡΙΑ'
ΑΛΛΙΩΣ_ΑΝ Δ > 25 ΚΑΙ Δ <= 30 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΥΠΕΡΒΑΡΟΣ.ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΚΙΛΑ! '
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΠΑΧΥΣΑΡΚΟΣ ΚΑΙ ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΕΠΕΙΓΟΝΤΩΣ ΚΙΛΑ!!!'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ ΔΜΣ

ΑΝ ΘΕΛΕΤΕ ΝΑ ΤΟ ΤΡΕΞΕΤΕ ΣΤΗ ΓΛΩΣΣΟΜΑΘΕΙΑ,Ο ΚΩΔΙΚΑΣ ΕΙΝΑΙ Ο ΠΑΡΑΚΑΤΩ
Σπόιλερ:

ΠΡΟΓΡΑΜΜΑ ΔΜΣ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:Β,Υ,Δ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΒΑΡΟΣ'
ΔΙΑΒΑΣΕ Β
ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΥΨΟΣ'
ΔΙΑΒΑΣΕ Υ
Δ <-- Β/(Υ^2)
ΓΡΑΨΕ 'Ο ΔΕΙΚΤΗΣ ΜΑΖΑΣ ΣΩΜΑΤΟΣ ΕΙΝΑΙ', Δ
ΑΝ Δ<=20 ΤΟΤΕ
ΓΡΑΨΕ 'ΕΙΣΤΕ ΑΔΥΝΑΤΟΣ.ΠΡΕΠΕΙ ΝΑ ΤΡΩΤΕ ΠΕΡΙΣΣΟΤΕΡΟ'
ΑΛΛΙΩΣ_ΑΝ Δ>20 ΚΑΙ Δ<=25 ΤΟΤΕ
ΓΡΑΨΕ 'ΕΙΣΤΕ ΣΤΑ ΚΑΝΟΝΙΚΑ ΟΡΙΑ'
ΑΛΛΙΩΣ_ΑΝ Δ>25 ΚΑΙ Δ<=30 ΤΟΤΕ
ΓΡΑΨΕ 'ΕΙΣΤΕ ΥΠΕΡΒΑΡΟΣ.ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΚΙΛΑ!'
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΕΙΣΤΕ ΠΑΧΥΣΑΡΚΟΣ ΚΑΙ ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΕΠΕΙΓΟΝΤΩΣ ΚΙΛΑ!!!'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Έχει επεξεργασθεί από τον/την Stavkor στις Σαβ Οκτ 09, 2010 9:40 am, 1 φορά
avatar
Stavkor
Πρωτάρης
Πρωτάρης

Αριθμός μηνυμάτων : 9
Ημερομηνία εγγραφής : 27/09/2010
Ηλικία : 26
Τόπος : Κορυδαλλός, somewhere high...

Επισκόπηση του προφίλ των χρηστών

Επιστροφή στην κορυφή Πήγαινε κάτω

Απ: Υπολογισμός Δείκτη Μάζας Σώματος

Δημοσίευση  Prince Of Porphyria Την / Το Παρ Οκτ 08, 2010 11:03 pm

γιατι οχι ετσι;
Σπόιλερ:
Αλγόριθμος ΔΜΣ
ΑΡΧΗ
ΕΜΦΑΝΙΣΕ 'ΔΩΣΕ ΤΟ ΒΑΡΟΣ'
ΔΙΑΒΑΣΕ Β
ΕΜΦΑΝΙΣΕ 'ΔΩΣΕ ΤΟ ΥΨΟΣ'
ΔΙΑΒΑΣΕ Υ
Δ <-- Β/(Υ^2)
ΕΜΦΑΝΙΣΕ ' Ο ΔΕΙΚΤΗΣ ΜΑΖΑΣ ΣΩΜΑΤΟΣ ΕΙΝΑΙ ', Δ
ΑΝ Δ <= 20 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΑΔΥΝΑΤΟΣ.ΠΡΕΠΕΙ ΝΑ ΤΡΩΤΕ ΠΕΡΙΣΣΟΤΕΡΟ '
ΑΛΛΙΩΣ_ΑΝ Δ > 20 ΚΑΙ Δ <= 25 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ 'ΕΙΣΤΕ ΣΤΑ ΚΑΝΟΝΙΚΑ ΟΡΙΑ'
ΑΛΛΙΩΣ_ΑΝ Δ > 25 ΚΑΙ Δ <= 30 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΥΠΕΡΒΑΡΟΣ.ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΚΙΛΑ! '
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ ' ΕΙΣΤΕ ΠΑΧΥΣΑΡΚΟΣ ΚΑΙ ΠΡΕΠΕΙ ΝΑ ΧΑΣΕΤΕ ΕΠΕΙΓΟΝΤΩΣ ΚΙΛΑ!!!'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ ΔΜΣ

Μου φαινεται πιο απλο και γρηγορο.

_________________
avatar
Prince Of Porphyria
Admin

Αριθμός μηνυμάτων : 26
Ημερομηνία εγγραφής : 27/09/2010
Ηλικία : 26
Τόπος : Κορυδαλλος

Επισκόπηση του προφίλ των χρηστών

Επιστροφή στην κορυφή Πήγαινε κάτω

Απ: Υπολογισμός Δείκτη Μάζας Σώματος

Δημοσίευση  Stavkor Την / Το Σαβ Οκτ 09, 2010 9:37 am

Το ίδιο είναι,αλλά δεν ξέρω αν τα παιδιά έχουν μάθει την δομή αλλιώς_αν. Αν την έχουν μάθει,θα κάνω ένα update.



UPDATED
avatar
Stavkor
Πρωτάρης
Πρωτάρης

Αριθμός μηνυμάτων : 9
Ημερομηνία εγγραφής : 27/09/2010
Ηλικία : 26
Τόπος : Κορυδαλλός, somewhere high...

Επισκόπηση του προφίλ των χρηστών

Επιστροφή στην κορυφή Πήγαινε κάτω

Επισκόπηση προηγούμενης Θ.Ενότητας Επισκόπηση επόμενης Θ.Ενότητας Επιστροφή στην κορυφή


 
Δικαιώματα σας στην κατηγορία αυτή
Δεν μπορείτε να απαντήσετε στα Θέματα αυτής της Δ.Συζήτησης